Modify

Opened 7 years ago

Closed 6 years ago

#49 closed defect (fixed)

BNC crash due to not catch exception

Reported by: droma@… Owned by: stuerze
Priority: normal Component: BNC
Version: BNC 2.1 Keywords:
Cc:

Description

I'm sorry, this is the first time for me reporting a BNC bug and I didn't found any procedure of how and where to do it. Please let me know if I'm reporting it at the wrong place or if you need any more information.

Recently our BNC (Bnc2.11.1-CentOS6-64bit-static) crashed with the following output message:

RTCM2_23::extract: P.nDataWords()>=1
RTCM2_23::extract: P.nDataWords()>=1
RTCM2_23::extract: P.nDataWords()>=1
Qt has caught an exception thrown from an event handler. Throwing
exceptions from an event handler is not supported in Qt. You must
reimplement QApplication::notify() and catch all exceptions there.

terminate called after throwing an instance of 'std::bad_alloc'
  what():  std::bad_alloc

The bnc_update.log doesn't show any information related to the error.

Attachments (0)

Change History (7)

comment:1 by stuerze, 7 years ago

Would it be possible, to give me access to the data stream, which is providing such error message?
Thanks in advance, Andrea.

comment:2 by anonymous, 7 years ago

I really don't know which is the one causing the error, we're feeding form around 150 different streams. Is there any way I could find it? I could also provide you with the log and the different mountpoints if it's any use for you, but since I will remove the user and password I don't know if you will have access to them.

comment:3 by stuerze, 7 years ago

The data stream providing the error message is one using RTCM format version 2.3.
I hope, you have not 150 data streams using RTCM version 2.* ;)

It would be helpfull to have access to the RTCM version 2.* data streams in order to reproduce the error. Otherwise, it's difficult to find the reason for the crash.
We would use your provided user name and password data for test purposes only.
Best regards, Andrea.

comment:4 by anonymous, 7 years ago

Dear Andrea,

you're right only four stations are in RTCM_2.3 format:

['www.euref-ip.net:2101/VIGO0', 'www.euref-ip.net:2101/ROVE0', 'www.euref-ip.net:2101/ALME0', '200.3.123.65:2101/RUFI0']

In case you don't have access to some of them, please let me know and I will ask our group manager if I'm allowed to share with you the user access information.

Be advised that BNC was running about two weeks before it crashed.

Regards,
David

comment:5 by anonymous, 7 years ago

Hmm, strange, I took a look at the caster http://200.3.123.65:2101/ and the station RUFI0 seems not to be listed there. When we started BNC it was there for sure. Could this be related to the problem?

comment:6 by anonymous, 7 years ago

Dear David,

thanks for your hints and the list of mount points. www.euref-ip.net is our own caster so we have access to its streams ;)

Furthermore, it is no problem for BNC, to handle disappearing mount points.

I will setup a long term test using a lot of RTCM2 streams in order to try to find the reason for the crash.

In case of success, the findings will flow in BNC version 2.12 that is under development and shall be available soon.

Thanks again and best regards,
Andrea

comment:7 by stuerze, 6 years ago

Resolution: fixed
Status: newclosed

BNC version 2.12 is released now: https://igs.bkg.bund.de/ntrip/download

Modify Ticket

Change Properties
Action
as closed The owner will remain stuerze.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.