Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 months ago

#24 closed defect (fixed)

Error description regarding GLONASS clocks sent by Loukis Agrotis

Reported by: stuerze Owned by: stoecker
Priority: normal Component: Clock & Orbit
Version: Keywords:
Cc: stuerze, mervart

Description

First message from Loukis:

Attached is a spreadsheet with the results of a manual reconstruction of the clocks for two GLONASS satellites and comparison against the batch files. The following are noted:

  1. There is a bias in the DLR results which is constant for both satellites
  2. The BKG and CNES results are very close for R02 (non-zero drift term) but significantly different for R01 (zero drift term). The BKG difference for R01 is very large.
  3. The GMV results for R02 are closer than for R01, but still different.

My suspicion is that there is a problem in using the GLONASS brdc drift term (or a misunderstanding on my part). In any case I am attaching extracts of the BNC decoded CLK files, the batch clock files that are submitted by the ACs, the reconstructed clock files that I generated and the brdc file for the relevant epoch (from CDDIS). Please note that the results I generated (gma, bka, cna, dla) are in exact agreement with the manual reconstruction in the spreadsheet. Also, the GPS results are very close, showing that the GPS satellites are properly encoded and decoded.

Files attached


Test results from Andrè Hauschild:

  1. I can confirm a 400ns (=120m) offset, which is identical for all GLONASS satellites, which corresponds to the GPS-GLONASS system time offset.
  2. After removing this offset, the batch and SSR clocks are virtually identical (~1mm level differences).


I conclude from these findings, that your way and my way of converting from RTCM-SSR to SP3 are consistent.

The 400ns-offset for all GLONASS sats shows up, because the clocks in my batch and my SSR solution refer to different system times. I could remove this offset, but I do not believe it does any harm (SPP/PPP users should estimate separate GPS and GLONASS clocks in any case), so I would prefer not having to make a software update. However, please let me know your thoughts on this!


Concluding remarks from Loukis:

Andre’s response reinforces my suspicion that there is an issue in the BNC encoding for GLONASS clocks where the drift term is non-zero.

Attachments (2)

DecodeResults.tar.gz (43.4 KB ) - added by anonymous 8 years ago.
GLONASSDecoding.xlsx (12.6 KB ) - added by anonymous 8 years ago.

Download all attachments as: .zip

Change History (5)

by anonymous, 8 years ago

Attachment: DecodeResults.tar.gz added

by anonymous, 8 years ago

Attachment: GLONASSDecoding.xlsx added

comment:1 by stoecker, 8 years ago

Cc: mervart added

Hmm, I only take and encode that data I get in the encoder. The values itself are supplied elsewhere. I doubt encoding is wrong for GLONASS only, as GLONASS and GPS use nearly the same code.

More likely is, that the data supplier already delivers these values.

comment:2 by loukis, 8 years ago

The concluding remark above should read:
Andre’s response reinforces my suspicion that there is an issue in the BNC encoding for GLONASS clocks where the drift term is zero.

comment:3 by loukis, 8 years ago

Resolution: fixed
Status: newclosed

The issue was due to a misunderstanding in the RTNET format change (to now include the relativistic correction) and is now resolved. Recommend closure of this ticket.

Modify Ticket

Change Properties
Action
as closed The owner will remain stoecker.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.