Modify

Opened 19 months ago

Closed 6 months ago

Last modified 6 months ago

#153 closed defect (fixed)

BNC is unable to open serial port

Reported by: mike Owned by: stuerze
Priority: normal Component: BNC
Version: Keywords:
Cc:

Description

I am using BNC v2.12.18 under Windows 10 64-bit. I have configured it to receive an NTRIP stream containing RTCM3 messages from a local caster, and this appears to be working. I now wish to configure BNC to forward the RTCM3 messages to a serial-connected GNSS receiver.

The GNSS receiver is an embedded module (mini-PCIe form factor) which appears in Windows as a virtual serial port (COM49). I have entered the mountpoint, port name and baud rate on the Serial Output tab, but BNC is consistently unable to open the port.

I have confirmed that the baud rate is correct and that the port exists in Device Manager.

I have confirmed that no other application has opened a connection to the port.

I have attached my BNC config file (with my credentials removed), a log file, and two screenshots.

What am I doing wrong?

Attachments (4)

BNC.bnc (3.1 KB ) - added by mike <michael.ody@…> 19 months ago.
bnc_221102 (18.2 KB ) - added by mike <michael.ody@…> 19 months ago.
BNC Serial Output tab.png (156.4 KB ) - added by mike <michael.ody@…> 19 months ago.
Device Manager serial ports.png (112.2 KB ) - added by mike <michael.ody@…> 19 months ago.

Download all attachments as: .zip

Change History (10)

by mike <michael.ody@…>, 19 months ago

Attachment: BNC.bnc added

by mike <michael.ody@…>, 19 months ago

Attachment: bnc_221102 added

by mike <michael.ody@…>, 19 months ago

Attachment: BNC Serial Output tab.png added

by mike <michael.ody@…>, 19 months ago

comment:1 by mike <michael.ody@…>, 19 months ago

Component: OtherBNC
Owner: changed from team to stuerze

comment:2 by mike <michael.ody@…>, 18 months ago

It's over a month since I created this ticket. Is this product supported?

comment:3 by stuerze, 18 months ago

Dear Mike,

I'm sorry but this is a very special question, which is difficult to solve from remote.
I have no experiences howto use virtual ports on windows. Maybe this helps:

https://www.virtual-serial-port.org/articles/com-port-on-windows-10/

Best regards, Andrea

comment:4 by stuerze, 6 months ago

Resolution: fixed
Status: newclosed

comment:5 by anonymous, 6 months ago

Hi Andrea,

Great to hear this issue has been marked as fixed. Is it possible to obtain a Windows binary of the latest build, or do I need to wait for an official release?

comment:6 by mike <michael.ody@…>, 6 months ago

Apologies, I should have said I'm the original creator of this ticket.

Modify Ticket

Change Properties
Action
as closed The owner will remain stuerze.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.