Modify

Opened 4 weeks ago

Closed 4 weeks ago

#129 closed defect (wontfix)

BNC with openssl1.1 on Debian 10

Reported by: hx97177@… Owned by: stuerze
Priority: normal Component: BNC
Version: Keywords:
Cc: pl

Description

Hello

I'm using bnc-2.12.9-ubuntu-64bit-shared on an Ubuntu server since many years.

Now I have to set up a new server with BNC. The new server is running Debian 10. I tried using bnc-2.12.18-debian8-64bit-static, but I'm getting the following error messages:

QSslSocket: cannot resolve CRYPTO_num_locks
QSslSocket: cannot resolve CRYPTO_set_id_callback
QSslSocket: cannot resolve CRYPTO_set_locking_callback
QSslSocket: cannot resolve sk_free
QSslSocket: cannot resolve sk_num
QSslSocket: cannot resolve sk_pop_free
QSslSocket: cannot resolve sk_value
QSslSocket: cannot resolve SSL_library_init
QSslSocket: cannot resolve SSL_load_error_strings
QSslSocket: cannot resolve SSLv3_client_method
QSslSocket: cannot resolve SSLv23_client_method
QSslSocket: cannot resolve SSLv3_server_method
QSslSocket: cannot resolve SSLv23_server_method
QSslSocket: cannot resolve OPENSSL_add_all_algorithms_noconf
QSslSocket: cannot resolve OPENSSL_add_all_algorithms_conf
QSslSocket: cannot resolve SSLeay
QSslSocket: cannot call unresolved function CRYPTO_num_locks
QSslSocket: cannot call unresolved function CRYPTO_set_id_callback
QSslSocket: cannot call unresolved function CRYPTO_set_locking_callback
QSslSocket: cannot call unresolved function SSL_library_init
QSslSocket: cannot call unresolved function SSLv23_client_method
QSslSocket: cannot call unresolved function sk_num
QSslSocket: cannot call unresolved function SSLv23_client_method
QSslSocket: cannot call unresolved function SSL_library_init

It seems that the problem is that the server has openssl version 1.1.1d. The old server e.g. has openssl 1.0.2g. Is the bnc software only working with openssl 1.0? I'm not allowed to downgrade the openssl version. Is there any other solution?

Many thanks for your help

Attachments (0)

Change History (1)

comment:1 by stoecker, 4 weeks ago

Resolution: wontfix
Status: newclosed

In general it is not possible to mix shared libraries over major versions. You only can install multiple versions of a library.

But adding to that it is not possible to mix even minor openssl versions. That's a security feature of openssl.

You need to compile the software for the system where you use it.

Modify Ticket

Change Properties
Action
as closed The owner will remain stuerze.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.