Modify

Opened 3 years ago

Closed 3 years ago

#113 closed defect (fixed)

bnc-2.12.9-debian8-64bit-static fails when using --nw option

Reported by: ljbade Owned by: stuerze
Priority: normal Component: BNC
Version: BNC 2.2 Keywords:
Cc:

Description

I am using bnc-2.12.9-debian8-64bit-static release on a Ubuntu 18.04 machine.

With the previous version I was using (2.12.6) the --nw option worked fine.

After updating to the latest release I now get this error:
Unable to load library icui18n "Cannot load library icui18n: (icui18n: cannot open shared object file: No such file or directory)"

The error only shows with the --nw option.

libicuil8n is installed.

Attachments (0)

Change History (5)

comment:1 by stuerze, 3 years ago

Thank you for this hint. We will generate an ubuntu version of BNC.
As soon as it is available, you will find it here: https://igs.bkg.bund.de/ntrip/bnc

comment:2 by wiese, 3 years ago

Please try ftp://igs.bkg.bund.de/NTRIP/software/bnc-2.12.9-ubuntu-64bit-shared.
You have to install:

sudo apt-get update && sudo apt-get install -y qt4-default libqtwebkit4 libssl1.0-dev

It is built on: Ubuntu 18.04.2 LTS Kernel: 3.10.0-957.10.1.el7.x86_64 x86_64 bits: 64

comment:3 by ljbade, 3 years ago

Ah yes that worked. Thanks!

I also figured out another problem I was having with the RINEX skeleton files yesterday, seems the behaviour has changed. I used to have to use the 4 character ID for the file, e.g. ABCD.SKL but now it seems it only matches the long name e.g. ABCD00USA.SKL

The caster I have been using has always had the long style mountpoints e.g ABCD00USA0

It was very confusing as there are no log messages in the log file for when BNC can't find a matching SKL file and the "skeleton mandatory" option is turned on.

comment:4 by anonymous, 3 years ago

Could you open a new ticket for that please?

comment:5 by wiese, 3 years ago

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Action
as closed The owner will remain stuerze.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.