Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#79 closed defect (invalid)

Glonass PRN

Reported by: regina.operation@… Owned by: stuerze
Priority: major Component: BNC
Version: Keywords:
Cc:

Description

I use the BNC version 2.12.1 and i notice that the PRN of glonass ephemeris are bad value (for rinex3.03 and rinex 2.11). For example a part of glonass ephemeris file (rinex 2.11):

51 16 5 24 14 15 0.0 3.240257501602e-04 3.637978807092e-12 5.040000000000e+04

We can see that the PRN is 51. Old version 2.11.1 take into account the good value of PRN.

Attachments (2)

BNC.bnc (2.7 KB) - added by regina.operation@… 3 years ago.
configuration file
raw_BRDC_rx3_files.zip (198.1 KB) - added by regina.operation@… 3 years ago.
part of Raw, BRDC and observation files

Download all attachments as: .zip

Change History (11)

comment:1 Changed 3 years ago by stuerze

Dear Colleague,

would you be so kind and provide me your BNC configuration file, so that I can see, what your input data are?

Thanks and best regards,
Andrea.

Last edited 3 years ago by stuerze (previous) (diff)

comment:2 Changed 3 years ago by stuerze

.. another good help to reproduce your error case would be small raw file: https://software.rtcm-ntrip.org/export/HEAD/ntrip/trunk/BNC/src/bnchelp.html#rawout

Regards, Andrea

Changed 3 years ago by regina.operation@…

Attachment: BNC.bnc added

configuration file

Changed 3 years ago by regina.operation@…

Attachment: raw_BRDC_rx3_files.zip added

part of Raw, BRDC and observation files

comment:3 Changed 3 years ago by stuerze

The erroneous GLONASS PRNs seem to be part of your RTCM input data stream. There are not many possibilities to make a decoding error and an independent software decodes such strange GLONASS PRNs as well:

RTCM3 (2016-05-25T08:59:03.28) Type 1020 (size 45):
  SV= 40, Freq=  5, tk=11:30:00(41400s), tb=11:45:00(705min,42300s)
  Almanac health=true (valid)
  X= 15920.4995117km, X velocity=     2.4971581km/s, X acceleration=  -9.31323e-10km/s2
  Y= -7985.3676758km, Y velocity=     0.0231647km/s, Y acceleration=   9.31323e-10km/s2
  Z= 18286.9921875km, Z velocity=    -2.1719027km/s, Z acceleration=  -9.31323e-10km/s2
  P1=1, P2=1, P3=0, Ephemeris health=0
  GammaN=9.09495e-13, tauN=-7.0611e-05, EN= 0, M=1
  GLONASS-M: P=1, ln(3)=0, delta tau=-2.79397e-09, P4=0, Ft=10, Nt= 146
  Additional Data=valid:
   NA= 146, tauC=-0.0000000140s
   GLONASS-M: N4= 6, tauGPS=-0.0000000224s, ln(5)=0
RTCM3 (2016-05-25T08:59:43.42) Type 1020 (size 45):
  SV= 58, Freq=  4, tk=11:30:00(41400s), tb=11:45:00(705min,42300s)
  Almanac health=true (valid)
  X= -5028.6523438km, X velocity=    -1.2788105km/s, X acceleration=   9.31323e-10km/s2
  Y= 12430.7070312km, Y velocity=    -2.6841803km/s, Y acceleration=   3.72529e-09km/s2
  Z= 21704.7304688km, Z velocity=     1.2393589km/s, Z acceleration=             0km/s2
  P1=1, P2=1, P3=0, Ephemeris health=0
  GammaN=1.81899e-12, tauN=-6.55986e-05, EN= 0, M=1
  GLONASS-M: P=1, ln(3)=0, delta tau=9.31323e-10, P4=1, Ft= 8, Nt= 146
  Additional Data=valid:
   NA= 146, tauC=-0.0000000140s
   GLONASS-M: N4= 6, tauGPS=-0.0000000224s, ln(5)=0

comment:4 Changed 3 years ago by stuerze

It seems to be an error with respect to septentrio receivers only. If I switch of all septentrio reseiver in our ephemeris stream generation I didn't get such strange GLONASS PRNs.

comment:5 Changed 3 years ago by stoecker

Resolution: invalid
Status: newclosed

Closing as invalid. Anyway the reason for the error in the original data should be investigated and reported to the relevant place (Septentrio)?

comment:6 Changed 3 years ago by stuerze

It's reported to 'support@…'

comment:7 Changed 3 years ago by anonymous

Dear Colleagues from "regina.operation",

The septentrio support team has written the following:

To get a better understanding of this issue, could you please send us the diagnostic report of the receiver? The diagnostic report can be generated in RxControl? from File > Display Diagnostic Report. Could you please also tell us in which RTCM message this issue is observed?

May I ask you to deliver the mentioned report to support at septentrio.com because we don't pursue such a receiver? We observed the issue within message type 1020 (GLONASS ephemeris).

Thanks and best regards,
Andrea.

comment:8 Changed 3 years ago by stuerze

The septentrio support team has meanwhile written the following:

I can inform you that I was in the meantime able to reproduce this. We are currently investigating this further and I will keep you informed.

comment:9 Changed 3 years ago by stuerze

New message from Septentrio support team:

We have now fixed the issue in RTCM MT1020 in v2.9.4 of the PolaRx4 firmware. The GLONASS satellite numbers are now correctly,

Modify Ticket

Change Properties
Action
as closed The owner will remain stuerze.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.